none
Hyper-V VM stuck in "Stopping" state

    Question

  • I'm running Hyper-V on a 2008 R2 server and for the 2nd time in as many months I've logged into a VM and restarted it but it's stuck in the "stopping" state in Hyper-V and doesn't give me any Turn Off, Shutdown, Save, Pause or Reset options.  The only thing I've been able to do is to schedule a time to reboot the Hyper-V server.  Has anyone else experienced this?  Is there any command I can run get the VM  top turn off  w/o having to reboot or restart the Hyper-V service?

    Thanks.

     


    Tom Owens
    Wednesday, October 12, 2011 9:51 PM

All replies

  • I have some issue, restart Hyper-V services can't resolve it.

    Wednesday, July 25, 2012 11:00 AM
  • Yeah! Path:

    1. Find wmwp.exe process for this VM (use handle.exe from russinovich to VM path)

    2. Kill process

    Wednesday, July 25, 2012 11:10 AM
  • I have the same thing happening here.   Every VM will hang on shutdown.   When they hang, if I leave them alone, they will, eventually, crash the service.   I can't believe other people aren't having this problem.

    Thursday, January 17, 2013 8:12 PM
  • In the case of Windows 2012 and Hyper-V I've determined that this is an issue with RRAS. If you have them both installed on the same machine, RRAS causes a network hang.

    The same is also an issue with Plex Server and several other popular network intensive applications (DLNA Servers especially).  This is a bug in RRAS in Windows 2012 that MS needs to fix.

    What will happen if you try and kill the vmwp.exe process is that it won't stop, and if you try and kill it again, you'll get an access denied error. You're only resolution is to restart the computer.
    • Edited by JohnGalt Wednesday, February 27, 2013 2:11 PM
    • Proposed as answer by David Trounce Friday, August 9, 2013 9:40 PM
    Wednesday, February 27, 2013 2:10 PM
  • I am having the same issue, and found others posting as well, been over a year since it was identified and MS still has not came out with a fix.? I never had this problem on our 2008 R2 cluster as others have, but having it now with our 2012 cluster. Any help would be appreciated..

    Found the following hot fix from MS, I am in the process of rotating our servers down to apply it.

    "Virtual machines freeze at the "Stopping" state after you shut down the virtual machines in Windows Server 2012" http://support.microsoft.com/kb/2823643


    • Edited by Phil Barclay Thursday, May 16, 2013 2:01 AM
    • Proposed as answer by Phil Barclay Thursday, May 16, 2013 2:03 AM
    Monday, May 13, 2013 4:19 PM
  • Same problem, VMs hanging with RRAS installed, but a year later.   Is there a fix for this available?

    Burt Harris, Windows Azure Storage

    Wednesday, April 9, 2014 5:18 AM
  • Same problem, VMs hanging with RRAS installed, but a year later.   Is there a fix for this available?

    Burt Harris, Windows Azure Storage

    I found no solution. In the end I simply took it down for maintainance and let the vital systems go to another server while I reinstalled that server completely.

    Rinse and repeat for every server affected.

    This solved the problem completely.

    Friday, April 11, 2014 5:58 PM
  • I have seen your suggestion multiple times (re: killing the vmwp.exe process) but the process seems "unkillable"! I run Russinovich's PROCESS EXPLORER in administrative mode, locate the process, right-click and choose "KILL PROCESS TREE" and inevitably I get the error message: 

    Error terminating vmwp.exe. Access is denied.

    I find it odd that this solution keeps showing up in other posts regarding Hyper-V - yet I've never been able to actually KILL the process! Does the KILL PROCESS action need additional credentials somehow to make it work?

    I know my problem with a STOPPING-CRITICAL state in Hyper-V is the linking of a non-legacy network adapter to my Broadcom adapter. But I INEVITABLY forget to create a legacy network adapter before I load an OS on a VM in Hyper-V and I get this problem each time! Because it appears impossible to kill the process I have to play with Hyper-V management service and multiple reboots before I can finally get a VM to shutdown - just so I can add the legacy network adapter and get it running again. 


    Russ Foszcz

    Tuesday, March 31, 2015 5:48 PM
  • Hi all,

    any other solution without rebooting the host?

    • Proposed as answer by gewonecolalight Thursday, December 31, 2015 10:33 PM
    Monday, August 10, 2015 7:19 AM
  • Same problem here, and we are in August, 2015. I didn't apply the KB2823643 because it's quite old. the only solution was to:

    - disable the hyper-v virtual networks and the underlying physical networks: this led the VMs on 'stopping-critical' to revert to 'running' or 'off' depending on the previous state.

    - switch all the VMs off

    - enable the network interfaces disabled above

    - remove the RAS role completely

    - restart the host server

    for the moment, I give up running hyper-v and RAS on the same server. waiting for a fix...


    • Edited by matro Friday, August 28, 2015 1:29 PM
    Friday, August 28, 2015 1:28 PM
  • Not a proper solution: "Access is denied" you cannot force kill a a VM when it's "in service"
    Monday, August 31, 2015 12:39 PM
  • Same problem here, and we are in August, 2015. I didn't apply the KB2823643 because it's quite old. the only solution was to:

    - disable the hyper-v virtual networks and the underlying physical networks: this led the VMs on 'stopping-critical' to revert to 'running' or 'off' depending on the previous state.

    - switch all the VMs off

    - enable the network interfaces disabled above

    - remove the RAS role completely

    - restart the host server

    for the moment, I give up running hyper-v and RAS on the same server. waiting for a fix...


    Alternative solution:

    1.Open CMD then 

    bcdedit /set hypervisorlaunchtype off

    This prevents VMs from starting up again after reboot.

    2.Trigger "Windows Security" screen (via Ctrl-Alt-Del)

    3.Hold CTRL and click power icon

    4.Choose Yes on "Emergency Restart" prompt

    Saturday, November 7, 2015 7:27 AM
  • Using Windows 10 Hyper-V with RemoteFX enabled I had the same problem.

    Although I was unable to kill the vmwp process, I was able to kill the remotefx process (rdvgm.exe) which resolved the issue for me.


    Tim Mangan MVP for App-V and Citrix CTP Author of AppV books: "The Client Book" and "OSD Reference Book" (http://www.tmurgent.com/Books )

    Sunday, November 15, 2015 6:11 PM
  • This is only a sample size of one - but I was able to get my VM in Windows Server 2012 Standard out of the Stopping state by restarting the RRAS service.  I assumed that since somehow the RRAS service was the problem - that quick stop and start fix whatever problem there was.  And this turned out to be true.

    Steps:

    Open services.msc

    Stop the service "Routing and Remote Access"

    check your hyper-v VM to make sure it has stopped

    Start the service "Routing and Remote Access"

    Of course, all your VPN connections will drop, but you make an omelette, you break a few eggs.

    • Edited by Dave M _ Tuesday, November 17, 2015 5:26 PM
    Monday, November 16, 2015 4:36 PM
  • Open services.msc

    Stop the service "Routing and Remote Access"

    I have been getting the stopping critical error on all my VM's restarts lately. I do have RRAS installed but dont use it. Disabling the service as per the above suggestion does not seem to work either. Really annoying that I have to reboot an entire production server just to reboot a VM. Will probably end up removing RRAS and doing that on a VM machine instead and hoping that fixes the issue.


    • Edited by VoSSer Wednesday, March 1, 2017 11:44 AM
    Wednesday, March 1, 2017 11:37 AM
  • Wow, this was originally posted in 2011, it's 2017, and it still is broken. Sad. I fixed it on my 2012 server by adding a 2nd NIC to it, and setting the virtual switch in Hyper-V to use the new NIC, and told Hyper-v to not allow the management OS to share it.

    I can now reboot a vm at will, and my RRAS service is still running.

    • Proposed as answer by Slickferret Tuesday, April 4, 2017 1:52 PM
    Tuesday, April 4, 2017 1:45 PM
  • hi 

    hier is answer. 

    go to taskmanager right clik any one virtual machine worker process. en select go to detail


    and now go to where state your all vm disk. search same user name as virtual machines name. 

    and back to task manager end kill same services as vm. and vm now self rebooting.

    sorry myenglish :)


    Friday, April 28, 2017 11:09 AM
  • This worked amazingly on Server2012r2. Too bad MS hasn't simply fixed the issue yet.
    Thursday, December 28, 2017 9:55 PM
  • Wow this worked like a charm. My virtual switch was already assigned to a 2nd NIC so I just in-checked the share option, I did not stop the RRAS service, performed a reboot and the server was back up in seconds.

    Thanks for the suggestion!

    Thursday, March 8, 2018 3:56 PM